Important Notices

The material contained in this publication (including any supplementary information) constitutes and contains confidential and proprietary information of Infor.

By gaining access to the attached, you acknowledge and agree that the material (including any modification, translation or adaptation of the material) and all copyright, trade secrets and all other right, title and interest therein, are the sole property of Infor and that you shall not gain right, title or interest in the material (including any modification, translation or adaptation of the material) by virtue of your review thereof other than the non-exclusive right to use the material solely in connection with and the furtherance of your license and use of software made available to your company from Infor pursuant to a separate agreement, the terms of which separate agreement shall govern your use of this material and all supplemental related materials ("Purpose").

In addition, by accessing the enclosed material, you acknowledge and agree that you are required to maintain such material in strict confidence and that your use of such material is limited to the Purpose described above. Although Infor has taken due care to ensure that the material included in this publication is accurate and complete, Infor cannot warrant that the information contained in this publication is complete, does not contain typographical or other errors, or will meet your specific requirements. As such, Infor does not assume and hereby disclaims all liability, consequential or otherwise, for any loss or damage to any person or entity which is caused by or relates to errors or omissions in this publication (including any supplementary information), whether such errors or omissions result from negligence, accident or any other cause.

Without limitation, U.S. export control laws and other applicable export and import laws govern your use of this material and you will neither export or re-export, directly or indirectly, this material nor any related materials or supplemental information in violation of such laws, or use such materials for any purpose prohibited by such laws.

Trademark Acknowledgements

The word and design marks set forth herein are trademarks and/or registered trademarks of Infor and/or related affiliates and subsidiaries. All rights reserved. All other company, product, trade or service names referenced may be registered trademarks or trademarks of their respective owners.

Publication Information

Release: Infor Distribution FACTS Release level 9.1.0 and later
Publication date: October 31, 2016
About this guide ........................................................................................................................................ 7
   Intended audience ............................................................................................................................ 7
   Related documents .......................................................................................................................... 7
   Contacting Infor ............................................................................................................................ 8

Chapter 1 Using FACTS .................................................................................................................. 9
   Welcome to Infor Distribution FACTS ............................................................................................ 9
   Key advantages ............................................................................................................................... 9
   Signing on to FACTS ...................................................................................................................... 9
      Option A: Logging into FACTS via the Sign On screen ............................................................... 10
      Option B: Environmental Variables for auto start ....................................................................... 10
      Options C and D: Logging into FACTS ...................................................................................... 10
      Additional functionality for the Sign On screen .......................................................................... 11
   Exiting the Sign on screen .......................................................................................................... 11
   Navigating FACTS ......................................................................................................................... 11
   Access codes ................................................................................................................................ 13
   FACTS icons ................................................................................................................................ 15
   Using the online help .................................................................................................................... 20
   Help button bar ............................................................................................................................ 20
      Navigation pane ........................................................................................................................... 21
      Topic pane .................................................................................................................................... 21
      Contents tab ............................................................................................................................... 21
      Search tab .................................................................................................................................... 22
      Index tab ....................................................................................................................................... 22
   Using date calendar ....................................................................................................................... 22
   Performing system backups .......................................................................................................... 22
      Recommended system backup procedures ............................................................................... 23
      Backup types ............................................................................................................................. 23
      Make sure you backup the following types of information: ..................................................... 23
Frequency of backups ........................................................................................................... 23
Scheduling .......................................................................................................................... 24
After the backup ............................................................................................................... 24
Off-Site Protection ............................................................................................................ 24

Chapter 2  Using FACTS programs .......................................................................................... 27
File maintenances .............................................................................................................. 27
Using file maintenance programs ....................................................................................... 27
To add a record (in multi-record F/Ms only): ................................................................. 27
To edit a record: ............................................................................................................ 27
To delete a record: ........................................................................................................ 28
To browse records: ....................................................................................................... 28
Types of file maintenance programs ................................................................................. 28
Single-record F/Ms .......................................................................................................... 28
Multi-record F/Ms ........................................................................................................... 28
Static File Maintenances .................................................................................................. 29
Nonstatic File Maintenances ............................................................................................ 29
Using inquiries .................................................................................................................. 29
Syncing and opening views as separate windows ....................................................... 29
Using the Sync feature and open views as windows .................................................... 30
To use Sync: ................................................................................................................ 30
Inquiry features at a glance .............................................................................................. 31
Setting inquiry preferences ............................................................................................. 32
Customizing column headers ......................................................................................... 32
Setting view preferences in FACTS inquiries ................................................................. 32
To set favorites: ......................................................................................................... 33
To hide views: ........................................................................................................ 33
Smart Views .................................................................................................................. 33
To use Smart Views: .................................................................................................. 33
Filters ............................................................................................................................... 33
Entering notes in inquiries .............................................................................................. 34
Using reports .................................................................................................................... 34
FACTS Report Formatter ................................................................................................. 34
Setting up general ledger breaks for Report Formatter .............................................. 35
FACTS Report Registers .................................................................................................. 35
Reports and Prints menu options .................................................................................... 36
Custom report layout .................................................................................................... 37
Report features at glance .............................................................................................. 37
<table>
<thead>
<tr>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>Setting the default printer (SMR999) ...........................................</td>
</tr>
<tr>
<td>Using print options in reports ......................................................</td>
</tr>
<tr>
<td>Fields for print options ..................................................................</td>
</tr>
<tr>
<td>Viewing reports on screen ..................................................................</td>
</tr>
<tr>
<td>Viewer menu bar ...............................................................................</td>
</tr>
<tr>
<td>Using report templates ....................................................................</td>
</tr>
<tr>
<td>Creating user-specific templates ..................................................</td>
</tr>
<tr>
<td>Creating system templates ................................................................</td>
</tr>
<tr>
<td>Setting a default printer using templates ......................................</td>
</tr>
<tr>
<td>Selecting existing templates .........................................................</td>
</tr>
<tr>
<td>Setting a default template ................................................................</td>
</tr>
<tr>
<td>Clearing a template .........................................................................</td>
</tr>
<tr>
<td>Deleting a template ..........................................................................</td>
</tr>
<tr>
<td>Changing a template name ..................................................................</td>
</tr>
<tr>
<td>Editing the order, range and properties stored in templates .............</td>
</tr>
<tr>
<td>Setting printer properties in templates ........................................</td>
</tr>
<tr>
<td>Using the Multiple Output Selection screen ......................................</td>
</tr>
<tr>
<td>Register formats and procedures ....................................................</td>
</tr>
<tr>
<td>Running registers ............................................................................</td>
</tr>
<tr>
<td>Audit trails ......................................................................................</td>
</tr>
<tr>
<td>Using reports, registers and prints as audit trails ...........................</td>
</tr>
<tr>
<td>FACTS Report Designer .....................................................................</td>
</tr>
<tr>
<td>Customizing reports .........................................................................</td>
</tr>
<tr>
<td>Editing field attributes ....................................................................</td>
</tr>
<tr>
<td>Fields for customizing reports .......................................................</td>
</tr>
<tr>
<td>Using searches ..................................................................................</td>
</tr>
<tr>
<td>Performance boosters ........................................................................</td>
</tr>
<tr>
<td>To use searches: ................................................................................</td>
</tr>
<tr>
<td>Using the Filter Selections Dialog Box ...........................................</td>
</tr>
<tr>
<td>Stopping the search ..........................................................................</td>
</tr>
<tr>
<td>Search features at a glance .............................................................</td>
</tr>
<tr>
<td>Using search preferences ...................................................................</td>
</tr>
<tr>
<td>Editing columns for the search browser ..........................................</td>
</tr>
<tr>
<td>Removing preferences ........................................................................</td>
</tr>
<tr>
<td>Exporting search results ...................................................................</td>
</tr>
<tr>
<td>Exporting search results to Excel ..................................................</td>
</tr>
<tr>
<td>Exporting search results to a flat file (ASCII) ..................................</td>
</tr>
</tbody>
</table>
About this guide

This guide describes workflow, concepts and procedures for using the Infor Distribution FACTS.

Intended audience

This guide is for FACTS end users, managers, in-house analysts, and trainers who require an understanding of the product and how to use it.

Related documents

You can find the documents in the product documentation section of the Infor Xtreme Support portal, as described in "Contacting Infor" on page 8.

Refer to the contents of the FACTS Version 9.1 & Incrementals folder located at www.inforxtreme.com. Click Search>Browse Documentation>FACTS> Version 9.1 & Incrementals to view a document tree similar to this.

  o FACTS Version 9.1 & Incrementals
    ▪ Installation and Administration Guides
      • Installation Guide
      • Product Compatibility Matrix
      • Hardware Guide
    ▪ Release Notes
      • 9.1.0 Release Overview
      • Incremental Release Notes
    ▪ Integrations
      • Infor Solutions
        o Infor Distribution Storefront
        o eCommerce
      • Credit Card
        o CenPOS
      • WMS
Contacting Infor

If you have questions about Infor products, go to the Infor Xtreme Support portal at www.infor.com/inforxtreme.

If we update this document after the product release, we will post the new version on this Web site. We recommend that you check this Web site periodically for updated documentation.

If you have comments about Infor documentation, contact documentation@infor.com.
Welcome to Infor Distribution FACTS

Infor Distribution FACTS leads the distribution industry with more than 4,300 installations. Its suite of 22 highly integrated modules addresses the needs of distributors in the areas of Electronic Commerce, Asset Management, Financial Management and Customer Service. FACTS ties together all of your business processes. Quotes convert easily into sales orders, while Purchasing gets automatic notification of any special order needs.

Key advantages

**Immediate access to information.** You are not required to memorize codes to locate information in FACTS. Using the search feature, you can quickly find and select information from a list, no matter how long it is. A variety of sort orders, filter options and multiple keywords help you pinpoint the information you need.

**Maximum value, low cost of ownership.** FACTS carries the lowest overall total cost of ownership in the industry. Technologies such as the Client Interface Service (CIS) and component-based architecture help keep hardware costs down and make it cost effective to customize the system to your company's needs.

**Local Sales and Service.** FACTS is supported by direct offices in selected cities and an unbeatable network of Authorized Affiliates located across the U.S. and Canada. With this team of more than 500 professionals dedicated to the success of FACTS in your business, we provide the best and most cost-effective local sales, service and support in the industry.

Signing on to FACTS

There are 4 ways FACTS to start FACTS:

A–The standard FACTS Sign-On screen is presented and you specify the user code, password and company.
Key advantages

B–If the environment variables for auto start are set, they take precedence. The specific environment variables that are checked are: SSI_USER, SSI_PASSWORD, SSI_COMPANY, SSI_RUNPROG, and SSI_AUTO_EXIT. The Environment variables are set as described in the sign-in process.

C–After one or more FACTS sessions are running on the workstation (all for the same FACTS user and company, counting as a single FACTS user) subsequent sessions will automatically be signed-in. This option (where the initial user sign-in session is prompted and subsequent sessions bypass the sign-in) is not called “Auto Sign-In”, requires no configuration, and is available all the time for all users.

D–Auto Sign-in (ASI) is enabled and indicates when a user doesn’t have a current FACTS session running and the user is automatically signed in (bypassing the log in screen) based on their domain and user name.

Option A: Logging into FACTS via the Sign On screen

Simply enter your
User Code,
Password,
Company Code and then press Enter on the keyboard or click Sign In.

Option B: Environmental Variables for auto start

If the environment variables for auto start are set, they take precedence. The specific environment variables that are checked are: SSI_USER
SSI_PASSWORD
SSI_COMPANY
SSI_RUNPROG
SSI_AUTO_EXIT
If SSI_USER is set, but there is any issue with any of the environment variable values (e.g. an incorrect password, unauthorized company, etc.) the PxPlus session will terminate. If all of the values are valid, the login process will proceed with the given values.

Options C and D: Logging into FACTS

For options C and D, command line options can be utilized to indicate which company to sign into and what program to run.

The available command line options are:
CO=xx, COMP=xx, or COMPANY=xx – to set the company number. If not set, the company will be defaulted from either the existing FACTS session or the user’s ASI default company.
PROG=xxxxxx or PROGRAM=xxxxxx – to set the program or menu to automatically run. The program will be run prior to presenting a FACTS menu. If the program is not a valid program or if the user doesn’t have permission to run the given program, it will not be run.

AUTO_EXIT, AUTOEXIT, or EXIT – used in conjunction with the PROG=, to indicate that after running the indicated program, FACTS should terminate automatically.

Option D: FACTS Auto Sign In (ASI)

Additional functionality for the Sign On screen

From the Sign on Screen, System Administrators, local FACTS personnel and other technical users can still get to the INSTALL menu and the BASIC prompt by clicking on the Infor® logo.

Click on the logo. In the entry prompt that appears, type Install to access the INSTALL menu.

Exiting the Sign on screen

There are several ways to exit the Sign On Screen. You can:

- Press **F4** at the User Code field
- Press **Esc**
- Click **End**.

Navigating FACTS

The FACTS menu system contains these components.

- A header ribbon containing the system date and time and three drop-downs: Communication, which contains Message and Phone Message programs to check email and phone messages,
- My Alerts which accesses the Alert Control Center (ACC) to review, respond to, or dismiss (delete) alerts specifically tied to a user,
- and User name, which contains a menu with these options.

<table>
<thead>
<tr>
<th>Option</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>User Preferences</td>
<td>Accesses User Preferences F/M (SMF440) to specify user preferences for each system user. These settings are derived from User Code F/M and other FACTS programs that provide default information for FACTS companies, users, and locations. Each user can modify their own settings using this program.</td>
</tr>
<tr>
<td>Change</td>
<td>Use this screen to select a different user profile. You can set up multiple</td>
</tr>
<tr>
<td>Feature</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Active Profile</strong></td>
<td>profiles with different defaults for warehouse, printer, etc. Then, if you need to change from working in warehouse 01 to warehouse 02, you can change the active profile and all of the default values will change. You do not need to have multiple logins to get different default values. The active profile is displayed when you enter this program. Whenever you change your active profile, all of the global default variables will be reset. If no default warehouse, department or branch is set in your active profile then it will be taken from the location record, if one is set up.</td>
</tr>
<tr>
<td><strong>Profile Maintenance</strong></td>
<td>Accesses User Profile F/M where you can add, edit and delete profile records. Upon returning, the last profile that was edited will be compared to the active profile and if different, FACTS displays a message so you can indicate if the active profile should be changed to this one.</td>
</tr>
<tr>
<td><strong>Set FACTS Date</strong></td>
<td>Accesses Set FACTS Date (SMU120) to set the system date for your FACTS' terminal. Usually, the system date is already set when you start up the system. If for some reason the date is incorrect, or for example, you need to set the date back a day to finish up yesterday’s work, the date can be changed. To set the date, specify the <strong>New Date</strong>. If the day is set more than three days from the current date a warning is given, but the day is still set to its new value. The current system date and time are displayed. Check the <strong>Use This Date</strong> check box to set the FACTS system time to the value you specified. Click <strong>OK</strong> for the new date to take effect. When the date is changed, it will be displayed in the upper left portion of the FACTS Main screen and surrounded by asterisks (*****). The date change lasts only for the session the FACTS user is logged into.</td>
</tr>
<tr>
<td><strong>Change FACTS Company</strong></td>
<td>Accesses Change Company (SMU200) to change from working in one company to working in another. Multiple companies can be set up in the FACTS system. However, you can work only in one specific company at a time. To switch from working in one company to another, the Change Company can be used at any time as long as you are authorized to work in the new company. To change companies, specify the company code to begin working in. The current company number and name appear at the top of the screen. Specify Yes or No to indicate whether to change companies (from current company to new). If you specify Yes (and you have proper authorization), the company is changed and the program returns to the menu. This option is only available if the <strong>FACTS Date Change</strong> check box is checked in User Code F/M (SMF410).</td>
</tr>
<tr>
<td><strong>Help</strong></td>
<td>Displays options for the About menu for FACTS and the Infor Copyright message. Click Help&gt; About Infor ERP FACTS to see the FACTS version you are running as well as support, licensing, and workstation information.</td>
</tr>
</tbody>
</table>
Sign Off     Logs you out of the system.

Below the header ribbon is the start-up menu location, the Main menu tab if the Allow Main Menu check box is checked, and an optional Primary menu tab if the Primary Menu prompt is specified on the Menu Setup tab of User Code F/M (SMF410).

Modules and drop-down menus are displayed on the main screen. The menu contains is drop-down modules on left side. The right side of the menu has drag and drop capability to place frequently used programs directly on the front of the main menu panel.

The panel and main screen enable you to open and close the FACTS module menu trees that contain sub menus for each module.

When you first log into FACTS, the navigation panel displays the master menu or, if your System Administrator created one, a customized start-up menu.

Double click on a plus-sign (+) menu selection in the panel to see any available sub-menus. If the selection links to another menu, that sub-menu displays to the right in the main screen. However, if the menu selection links to a program (entry, file maintenance, report or inquiry), nothing appears in the main screen.

If you double click on a selection in the navigation panel, two things can occur:

If the selection links to a program, the program opens.

If the selection links to another menu, the menu appears in the navigation panel, taking the place of the previous menu. Depending on which selection is highlighted, another menu can appear in the main screen or the screen can remain blank.

Programs and sub-menus can be deleted from the Main menu by highlighting the program or submenu and pressing the Delete key. Those programs and submenus can be restored by right-clicking from the Main program menu and clicking Hidden Menu Items. On the Hidden Menu Items (SMS200) screen, highlight the lines containing the programs you want to restore to the Main menu and click Delete. At the message: Delete this line? Specify Yes and click OK. The program or submenu will be removed from the Hidden menu and returned to the Main menu.

Use the Access prompt to specify a module code or program code to display the module menu dialog box or program. For example, if you specify SME, the System Management End of Period menu dialog is displayed.

Access codes

To speed up access to different menus and programs, the FACTS system uses access codes as shortcuts to move around the system.

The following codes are preset for your convenience. Users can set up their own access codes in Program F/M (System Management>Menus>Program F/M).

The FACTS access codes for each module are listed here.
<table>
<thead>
<tr>
<th>Access code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>AP</td>
<td>Accounts Payable</td>
</tr>
<tr>
<td>AR</td>
<td>Accounts Receivable</td>
</tr>
<tr>
<td>CS</td>
<td>Counter Sales</td>
</tr>
<tr>
<td>EDI</td>
<td>Electronic Data Interchange</td>
</tr>
<tr>
<td>EW</td>
<td>Electronic Warehouse Management System</td>
</tr>
<tr>
<td>FL</td>
<td>FaxLink</td>
</tr>
<tr>
<td>GL</td>
<td>General Ledger</td>
</tr>
<tr>
<td>IC</td>
<td>Inventory Control</td>
</tr>
<tr>
<td>JC</td>
<td>Job Cost</td>
</tr>
<tr>
<td>JS</td>
<td>Job Stream</td>
</tr>
<tr>
<td>MC</td>
<td>Manufacturing Control</td>
</tr>
<tr>
<td>MM</td>
<td>Master Menu</td>
</tr>
<tr>
<td>OA</td>
<td>Office Automation</td>
</tr>
<tr>
<td>PO</td>
<td>Purchase Orders</td>
</tr>
<tr>
<td>PR</td>
<td>Payroll</td>
</tr>
<tr>
<td>RW</td>
<td>Report Writer</td>
</tr>
<tr>
<td>SA</td>
<td>Sales Analysis</td>
</tr>
<tr>
<td>SM</td>
<td>System Management</td>
</tr>
<tr>
<td>SO</td>
<td>Sales Orders</td>
</tr>
<tr>
<td>SR</td>
<td>Service and Repair</td>
</tr>
</tbody>
</table>

You can also access various master menus by combining the module access code with one of the following letters:

I Inquiries
R Report
E End of Period
F File Maintenance

IF Infrequent File Maintenance

Tip: Also try combining module access codes with the selection numbers found on the character-based menus. For example, type AP1 to jump over to AP Document Entry (APE110).

Other handy access codes are listed here.

OE SO Order Entry
DI SO Direct Invoice Entry
CS SO Counter Sale Entry
CM SO Credit Memo Entry
II IC Item Inquiry
CI AR Customer Inquiry

FACTS icons

The tables displays the icons that are used in different FACTS activities. The tables are grouped by functionality.

Use these icons to manage records, such as documents and items.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="New" /></td>
<td>New&lt;br&gt;Creates a new record in 3-level (header, lines, footer) entry programs.</td>
</tr>
<tr>
<td><img src="image" alt="New Record" /></td>
<td>New Record.&lt;br&gt;Creates a new record in entry and maintenance programs.</td>
</tr>
<tr>
<td><img src="image" alt="Edit" /></td>
<td>Edit&lt;br&gt;Places the selected record in edit mode so you can update it.</td>
</tr>
<tr>
<td><img src="image" alt="Insert" /></td>
<td>Insert</td>
</tr>
</tbody>
</table>
## Access codes

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1.png" alt="Icon" /></td>
<td>Creates a new record or line and places above the selected line in a grid or browser.</td>
</tr>
</tbody>
</table>
| ![Icon](image2.png) | Delete  
Removes the selected record. |
| ![Icon](image3.png) | Cancel or Stop  
Ends line entry mode. |
| ![Icon](image4.png) | Save  
Saves the new or edited record. |
| ![Icon](image5.png) | Next  
Displays the next record in a listing, report or program.  
-OR-  
Add (new) Next  
Adds another header record using the term Next until the header information is completed and the record is saved. |
| ![Icon](image6.png) | Last  
Displays the last record in a listing, report or program.  
-OR-  
Never Expires (For expiration dates, this icon represents Never as the expiration date.) |
| ![Icon](image7.png) | Previous  
Displays the former record in a listing, report or program. |
| ![Icon](image8.png) | First  
Displays the first record on file in a listing, report or program. |
| ![Icon](image9.png) | Backup  
Deletes the last value in a grid. |
| ![Icon](image10.png) | Options  
Accesses a dialog box for setting options for a feature, such as setting a contract scope. |
<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
</table>
| ![Icon](image1.png) | Primary Search  
Uses the specified filter parameters to display records. |
| ![Icon](image2.png) | Document Search  
Accesses the Search feature to use specified filter parameters to display records. This icon indicates a secondary search for a field such as customer, vendor or document in FACTS entry programs. |
| ![Icon](image3.png) | All  
Includes all records available for a field. |
| ![Icon](image4.png) | Ship To  
Displays the Ship-to Address dialog where you can specify the ship-to address for a warehouse or company. |
| ![Icon](image5.png) | Change Unit of Measure  
Displays the Change Unit of Measure dialog box so you can specify the desired selling or pricing unit of measure for an item. |
| ![Icon](image6.png) | ASAP  
Specifies "as soon as possible" as the order requested date. |
| ![Icon](image7.png) | Price Search  
Accesses the Price Search feature for default and alternate pricing. |
| ![Icon](image8.png) | System Date  
Uses the FACTS system date as the field value. |
| ![Icon](image9.png) | Due Date  
Uses the document due date as the field value. |
| ![Icon](image10.png) | Exit  
Closes the current screen or view. |
| ![Icon](image11.png) | Use Current Period  
Uses the FACTS current system period as the field value. |
### Access codes

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
</table>
| ![Icon](image1) | Use Past Period  
Uses the FACTS past system period as the field value. |
| ![Icon](image2) | Add Customer  
Accesses the Quick Customer Add feature. |
| ![Icon](image3) | Paid  
For any payment field, places the balance amount in the field. |
| ![Icon](image4) | Same  
Use the same information specified in a previous field. For example, use the ordered date as the promised and/or requested dates. |
| ![Icon](image5) | Refresh  
Reloads the screen, browser or grid display with current information. |
| ![Icon](image6) | Skip or Undo  
Removes changes to a new or edited record or skips a record when making changes to a group of records. |
| ![Icon](image7) | Swipe  
Indicates to the system, you are using a credit card magnetic swipe bar to read credit/debit card information. |
| ![Icon](image8) | Warehouse/Direct Ship  
Accesses the Warehouse/Direct Ship Selection dialog box, where you can specify the shipment type and sales order document for the warehouse shipment or direct from vendor shipment types. |
| ![Icon](image9) | Job Cost Entry  
Accesses the Job Cost Entry program to add job information associated with a document |

This icon has three options.  
**Balance Entry**
<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1.png" alt="Image" /></td>
<td>For Debit and Credit fields, uses the remaining or undistributed balance as the field value. Set to Current Period For accounting periods, sets the field values to the current period. Add to Batch Total For batch total amounts, adds the amount to the batch total.</td>
</tr>
<tr>
<td><img src="image2.png" alt="Image" /></td>
<td>New Electronic Batch or Quick Entry (Returns) Accesses the New Electronic Batch program where you can create electronic payment batches or the Returns Quick Entry program for customer returns.</td>
</tr>
<tr>
<td><img src="image3.png" alt="Image" /></td>
<td>Cash or Miscellaneous Cash Assigns a check payment type of cash or assigns miscellaneous cash as a customer</td>
</tr>
</tbody>
</table>

Use these icons to manage notes, inquiries and resources for customers, items, documents and vendors.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image4.png" alt="Image" /></td>
<td>Customer Note or Resource Displays customer notes or supplemental resources.</td>
</tr>
<tr>
<td><img src="image5.png" alt="Image" /></td>
<td>Item Note or Resource Displays item notes or supplemental resources.</td>
</tr>
<tr>
<td><img src="image6.png" alt="Image" /></td>
<td>Document Header Note Displays document header notes.</td>
</tr>
<tr>
<td><img src="image7.png" alt="Image" /></td>
<td>Document Line Note Displays document line notes.</td>
</tr>
<tr>
<td><img src="image8.png" alt="Image" /></td>
<td>AR Document Note Displays AR document notes.</td>
</tr>
<tr>
<td><img src="image9.png" alt="Image" /></td>
<td>Vendor Note or Resource</td>
</tr>
</tbody>
</table>
Help button bar

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![v]</td>
<td>Displays customer notes or supplemental resources.</td>
</tr>
</tbody>
</table>
| ![sync] | Sync  
Synchronizes the current program with other programs in FACTS, particularly order entry programs. |
| ![stop-sync] | Stop Sync  
Stops the synchronization between the current program with other programs in FACTS, particularly order entry programs. |
| ![alerts] | Alerts  
System alerts are active and available. |
| ![messages] | Messages  
Accesses the Phone Message Entry or General Message Entry programs to view messages. |

Using the online help

The FACTS Online Help System uses a tri-pane window format and displays in your Internet browser.

The tri-pane window in the Online Help System consists of these elements.

- Button bar (top)
- Navigation pane (left)
- Topic pane (right)

Help button bar

From the button bar, you can choose the following functions, listed left to right:
Contents to display the TOC pane.

Index to display the index pane.

Search to display the search pane.

Hide/Show to toggle the Navigation pane on or off.

Print to print the currently displayed topic.

Back to back up to the last topic you viewed.

Forward to display the next topic listed in the TOC.

Send Feedback to access your default email program, paste the topic file link in the email body, the topic title in the subject line and address the email to documentation@infor.com.

Navigation pane

The narrow pane to the left of the screen contains the Contents (TOC) tab, Index tab, and Search tab.

Topic pane

This is where the selected help topic appears. If a topic extends beyond a Window, use the scroll bars to see the rest of the topic. Topics can contain graphics, links to other topics and links to external Web sites, such as the Nexus.

You can print topics to any Windows printer, and you can annotate them. This is a helpful feature for FACTS users who need to add company-specific information to a topic or just add their own general notes. Annotations are user specific.

In addition, you can bookmark topics. This feature is useful if you frequently need to refer to certain topics. Bookmarks also allow you to mark your place if you are interrupted.

Contents tab

The TOC tab in left pane is look up method that uses a Table of Contents presentation. Each book represents a separate module.

Click on a book to see all the topics it contains. You may notice that the topics are broken down into menus and programs, similar to the FACTS menu system.

Use this look up method if you are used to finding information with the table of contents in FACTS paper manuals or if you are following along with the FACTS menu system.

This method is also helpful if you know which program you are looking for and which module it is in.
Search tab
This navigation option provides a full-text search of the entire help system. If you have trouble locating a help topic in Contents and Index, try Search.

Once you enter the keyword or keywords you are looking for, the help system shows you a list of synonyms in the middle box and a list of help topics that contain your keywords and the synonyms.

Select a topic from the bottom box.

The default sort orders for Item, Customer and Vendor are now set to Alpha in all Inquiries and Searches.

Index tab
The index is one of the more popular methods of navigating through online help information.

The index contains a list of keywords, through which you can scroll.

If you have a keyword in mind, enter it in the field at the top of the list box.

As you type a keyword, the list box scrolls to find the closest match. Look not only at the topic highlighted, but also at the topics immediately underneath it to see if the help system found your topic.

Like any keyword search, you may find that it takes several tries to get to the topic for which you are looking.

Using date calendar
Date fields in FACTS can now display a calendar pop up window.

To display the calendar press Shift F2 in any date field.

Performing system backups
Your company's computer system represents a major investment, and this investment needs to be protected as much as possible.

You can protect your computer hardware through periodic preventive maintenance provided by your hardware vendor.

In a similar fashion, you can protect your software investment by performing routine backups. Think of backups as medical insurance: In the event of a catastrophic illness, it is wise to have that safety net so you don't have to bear the entire financial burden.

**We cannot understate the importance of system backups.** If data is lost, through hardware problems or through user error, your backups usually can restore most of it.
Performing system backups

However, the work done between the time of the last backup and the data loss must be re-entered.

Obviously, the more frequent your backups, the less data you lose. For this reason, we recommend that you backup your system every day.

Recommended system backup procedures

We recommend that you backup on tape because it is faster and more reliable than diskettes.

Performing regularly scheduled backups provides insurance against loss of your computer information due to hardware failure, fire, electrical failure, user errors, theft or natural disasters (tornado, hurricane, flood, lightening, etc.).

If loss or damage occurs, you can restore the copy of information on tape, back onto your computer system. Consequently, if you don’t perform regularly scheduled backups, you risk having to re-key an extensive amount of information.

PLEASE BACKUP YOUR SYSTEM DAILY.

As soon as your system is installed, establish a backup procedure. Discuss the procedure with your local FACTS office to make sure the procedure is satisfactory.

Make sure the procedures are in place before anyone begins entering data so that you can backup additions and changes made to any data files.

Backup types

Your computer system stores different types of information. Depending on the type of computer system installed, you will have an operating system, a language, application programs, data, and other miscellaneous software installed (i.e. Third Party Products, word processing software and documents, spreadsheets, etc.)

Make sure you backup the following types of information:

- FACTS Data (your company files such as the customer files, item files, etc.)
- FACTS Programs and Data
- Full System (all of the information above plus the operating system, language, word processing software, spreadsheet program, etc.)

Frequency of backups

Remember restoring any backed up files only returns your system to the state it was in when the backup was made.

The above recommendations pertain to FACTS backups. If you have other third party programs that work with FACTS, or other productivity programs such as word processing or spreadsheet software, make sure you backup these programs and data as well.
Performing system backups

Scheduling

Once you have planned the type and frequency of your backups, establish a schedule (day and time) for making backups and adhere to the schedule. Give your users advanced warning about the schedule so they can plan accordingly.

We recommend that all users sign off the system before backup begins. Try to perform backups first thing in the morning or at the end of the day.

After the backup

First and foremost, verify that the backup actually happened.

Many systems ship with backup scripts that verify the tape after the backup has been performed. Some suggested methods of tape verification:

Set up a UNIX script that creates an extra file. Make sure it's the first file on the backup tape. This file should contain the time and date stamp of when the backup was performed. This gives you at-a-glance verification.

Set up a script to send UNIX mail to root. Set it up so that the message contains a list of files that were written to the backup tape. The System Administrator can compare the "backup" mail each day and against the tape to make sure the two reconcile.

Look for a file with the current time and date. When a UNIX system writes to a file, it normally updates the time and date stamp on that file. For example, say a user entered new customers (ARCUST) to the system prior to the backup at the end of business Friday, July 1. If the date on ARCUST is Friday, July 1, the backup was successful.

Off-Site Protection

Store a backup copy off-site. This provides an additional level of protection from natural disasters. At the minimum, store your weekly and monthly backups off-site.
File maintenances

File maintenance programs create the foundation of the FACTS system. They enable users to enter file information (such as customer, item and vendor files) and control how the system processes information, as in SO Static Control.

If you attempt to exit a file maintenance program without saving your changes, FACTS displays a message asking if you want to exit without saving your changes.

Often called F/Ms for short, these programs often function the same way.

Using file maintenance programs

To add a record (in multi-record F/Ms only):

1. To create a new record, press New.
2. Enter a unique code. These are usually alphanumeric and their lengths vary from program to program.
3. Complete the fields. Some file maintenances contain several tabs of fields. As you finish entering information on one tab, the program automatically advances you to the next one.
4. When you complete all the fields, press Save. To exit the program and return to the main menu, press Exit.

To edit a record:

1. To edit an existing record, enter the record code.
2. Press Edit and modify the necessary fields.
3. When you complete all the fields, press Save. To exit the program and return to the main menu, press Exit.
To delete a record:

1. To delete an existing record, enter the record code.
2. After you display the desired record, you can press **Delete** to remove it. Click **Yes** to confirm.

To browse records:

In a multiple-record file maintenance, press **F3** to bring up the first record on file or enter a code.

**Types of file maintenance programs**

File maintenance primarily come in two flavors:

- Single record
- Multi-record

**Single-record F/Ms**

File Maintenance programs that fall into this category consist primarily parameters that affect the behavior of other programs and entries throughout the system.

A FACTS Implementation Consultant usually sets these file maintenances up during the system installation and configuration. These file maintenances are crucial the way your system operates.

Because of the impact they have on the system, users should not change any of the settings in single-record F/Ms without consulting the company's System Administrator or a representative at the local FACTS office.

Static and Mosaics Control F/Ms found in each of the modules are examples of single-record F/Ms.

**Multi-record F/Ms**

These programs enable users to enter and maintain multiple records in the system. For example, Customer F/M lets you create a file for each customer containing general information, such as address and contact information, in addition to details, such as tax-related data and shipping preferences.

When you create a record in this type of FM, the record is given a unique identifier called a key. In some cases, FACTS can automatically assign keys, or users can assign keys manually.

Fields that require you to field a key in a multi-record F/M are always differentiated from other fields on the screen.

The field where you enter the key is set off from other fields by a rule or, in large F/Ms, by a set of tabs.
Static File Maintenances
Information in these file maintenances stays the same until a user changes them. Each module has its own Static Control F/M.
Static Control F/Ms for each module reside on the Infrequent File Maintenance menus.

Nonstatic File Maintenances
Like Static Control F/Ms, each module has its own Nonstatic Control F/M and they are not often used in day-to-day operations. However, the system continually updates some or all of the information in these file maintenances.
Nonstatic Control F/Ms for each module reside on the Infrequent File Maintenance menus.

Using inquiries

Syncing and opening views as separate windows
Inquiries are similar to searches in that they enable you to look up information stored in the system. However, inquiries provide much more in-depth information than searches.

Sync! You may find it helpful to have inquiries open while you are working in entry programs so you can view information as you enter invoices, orders, purchase orders, etc. If you are entering purchase orders, for example, it may be beneficial to have the Vendor Inquiry program open at the same time.

*The following applies only to IC Item Inquiry, AP and PO Vendor inquiries, GL Account Inquiry, AR and SO Customer inquiries.*

1. Look up the record on which you want to inquire by selecting Open to access Search screen and then entering the value in with the Go To field.

In the Vendor Inquiry, for example, enter a vendor number, alpha lookup or beginning characters of a vendor’s name.

You do not need to press the Enter key to select your inquiry focus. Highlight the desired line item. Some inquiries offer multiple sort orders, which can be accessed from the Sort By menu option.

Select the Change Filters button if you want to limit the number of records that appear in the inquiry browser. You can also access filters by choosing Options-->Filter Values from the menu.

Press CTRL + > or the horizontal scroll bar to scroll horizontally to view additional inquiry browser record information.
Using file maintenance programs

2. Select an inquiry view.

To select a view, press Shift + > and Shift + < to change the view to the left or right. You can also choose a view option from the view bar by using the << (left) and >> (right) arrow keys on the screen or select View from the menu bar and select a view from the dropdown menu.

In Inquiry programs, the list of views is in the tab order; tabbing from the main selection field of any inquiry will take you to the view list, and you can use the arrow keys to navigate through the views.

The Previous/Next/Search buttons at the top right corner of the Inquiry window are also in the tab order. The buttons are accessed with a Shift-Tab from the view list.

If line detail is available, select a line and click Line Detail or double click the icon at the beginning of the line.

Filtering views: In some inquiries, such as PO Vendor Inquiry, GL Account Inquiry and IC Item Inquiry, views can be filtered by warehouse, beginning period, item type and ship-to address.

To filter views: click Options>Filter views from the menu.

Using the Sync feature and open views as windows

Sync is a method of connecting the entry programs with information displayed in customer, item and vendor inquiries. It is a helpful feature because it enables you to get real-time information such as customer balances, vendor balances and warehouse quantities, while you are working in entry programs.

You can initiate Sync from the following programs:

- SO Customer Inquiry (SOI610)
- AP Vendor Inquiry (API610)
- AR Customer Inquiry (ARI610)
- IC Item Inquiry (ICI610)

Inquiries are synchronized on a per user basis. In other words, if you are signed on to FACTS in one window with one name and signed on in another window with another name, it will appear as if the Sync function is not working.

To use Sync:

Technical note
- While Sync mode is activated, the inquiry program will examine a file called SMUSED approximately every three seconds. This file contains the last customer number, item number and vendor number input in Sales Order Entry. If this number is different than the one currently being displayed in the inquiry, the inquiry will change its display to show information on this new customer, item or vendor.
1  Open the inquiry and entry programs you want to use.

2  In the inquiry window, click **Options>Synchronized Inquiry**.

3  At this point you can choose to view information from the main inquiry window, or you can open views as separate windows.

   *To open a view as a separate window, first select it and then choose Options>Open View as Separate Window. To open additional view, repeat these steps.*

4  Minimize the main inquiry window and, if necessary, arrange the separate view windows on your screen. (The next time you open this inquiry, FACTS will open the same views in the same position in which you placed them.)

5  **To turn off the Sync feature click End Sync.**

Inquiry features at a glance

Inquiries arrange data into different views so you stay on top of your job. Whether you're analyzing data or entering orders, inquiries get historical information working for you quickly.

**You can**

Open Inquiry views in separate windows from the main Inquiry window.

Take advantage of last-open memory, which remembers the last views used and their arrangement on screen (if opened in separate windows).

Define favorite views so they are easy to access.

Activate Smart Views so the system can track which views they use the most. Views with the most "hits" go to the top of the menu and the beginning of the View Bar.

Use multiple sort orders, filters and keywords to find needed information quickly.

Sync with other programs in FACTS, particular order entry programs so they can see needed data while working in the order screen.

Disable Views for basic Inquiry functionality.

Restrict groups of users from seeing entire views or individual fields containing sensitive information (technical users only).

Add custom views (technical users only).

The default sort orders for Item, Customer and Vendor are now set to Alpha in all Inquiries and Searches.
Setting inquiry preferences

Inquiry preferences are similar to search preferences. This function lets you personalize certain inquiry functions that relate for finding records.

Click **Options>Inquiry Preferences** from the menu bar to access preferences.

- Choose the search order that you want to default to when you open the inquiry.

Check the **Save as User Defaults** flag to save settings as your user defaults.

- Choose which filters you want to appear in the Filters window.

Click **Column Headers** to rearrange the search (top) browser column headers in the order you wish to see them.

**To reset preferences and filters to the system defaults**, click **Options>Reset to System Defaults**.

Customizing column headers

The Display Choices window shows the column headers that are available for display. The column headers that actually appear and the order in which they appear are shown in the Current Information box.

To change the order in which column headers appear for the sort order selected:

1. Make sure you have the right sort order selected in the Inquiry Preferences window (**Options>Inquiry Preferences**).
2. Click **Column Headers**.
3. Highlight the column header you want to move and click the single left arrow button to move it to the Display Choices box.
4. In the Current Information box, select a column header and click the single right arrow button. This inserts the column header you are moving above the one you selected.
5. Repeat steps 2 and 3 until the column headers are ordered the way you want them.
6. Use the double arrow buttons to move the entire list of column headers to one side or the other.
   
   You can also lock a number of columns so they remain in place as you scroll horizontally in the browser.

Setting view preferences in FACTS inquiries

Inquiries such as Item Inquiry include almost to 30 views. You can use the View Preferences option in each inquiry program quickly access the views you use most and hide those you don’t use at all.

View preferences are user- and program-specific, which means the preferences you set in Item Inquiry will not affect the View order in Customer Inquiry, nor will they affect another FACTS user running Item Inquiry.
The favorites set in View Preference are prioritized over Smart Views.

To set favorites:
1. Click Options>View Preferences.
2. Click the view in the list box and check Favorite.
3. Repeat the first two steps to set more views as favorites.
4. Click OK when you are done to return to the main inquiry window.

The views you set as favorites appear at the top of the view menu and the beginning of the view bar in the order you select them.

To hide views:
1. Click Options>View Preferences.
2. Click a view in the list box and click Hide.
3. Repeat the first two steps to hide additional views.
4. Click OK when you are done to return to the main inquiry window.

Smart Views
Use this feature in FACTS inquiries to help you quickly access the views you use most. With smart views on, FACTS tracks which views you use most often and places them at the beginning of the View menu and the view bar.

The system determines your favorite views by tracking how many times you hit (or select) a view.

Tip: You must be in a view for at least five seconds for it to count as a hit. That prevents FACTS from mistaking views that you quickly flip through as favorites.

- When Smart Views are on, FACTS prioritizes your favorite views in the following order:
  - Views you marked as favorites in the View Preferences window.
  - The number of Smart View hits in descending order.

The view order set in the SMVIEW Developer’s Tool by your local FACTS Affiliate.

To use Smart Views:
1. Click Options>Smart Views. To turn Smart Views off, click Options>Smart Views again.
2. Click Options>Reset Smart Views to remove any previously stored hits and start over.

Filters
Filters help you narrow down your searches more quickly.
Entering notes in inquiries

Notes are useful for documenting miscellaneous information about each vendor, item, customer document, or account used in FACTS.

For the inquiry programs listed below you can add or modify notes via Options-->Item Note Entry, Vendor Note Entry, or Customer Note Entry menu option as appropriate:

AR Customer Inquiry (ARI610)
AP Vendor Inquiry (API610)
Item Inquiry (ICI610)
PO Vendor Inquiry (POI610), SO Customer Inquiry (SOI610)
PO Document Inquiry (POI620)

The system displays the Note Entry (SME710) program. Refer to the How to enter and maintain notes for AR documents, customers, items, or vendors topic for step-by-step instructions.

Using reports

There are three types of reporting programs in FACTS.

Report programs print information in a specific format, but they do not update the system. An example is the Open Receivables Report, which lists all the open receivables in the system along with other information. Print programs output to forms, such as checks, 1099s, invoices, purchase orders, bills of lading, etc.

FACTS Report Formatter

The Report Formatter brings more flexibility, convenience and functionality to FACTS reports by allowing you to customize changes to FACTS report output without the modification of standard code. FACTS Report Formatter allows you to expand their report output options in a variety of ways to further enhance the way they gather information from FACTS.

The Report Formatter also allows you to print to more than one output for each instance of a report. For example, a report can print to Excel, the viewer, and to a printer all in one print run. To access the multiple output feature simply click the Multiple option from the Print Options screen.

The FACTS Report Formatter also supports supply chain management needs by providing report output to XML. You can print directly to a TCP/IP port or to a file with customized XML tags for each supply chain partner.
Those reports that use the Report Formatter can take advantage of new output types. Properly configured, you can print reports to:

- Excel
- XML (Can print to TCP/IP port)
- ASCII Delimited (Can print to TCP/IP port)
- Other (Programmer defined)
- HTML to a file

You can manage security concerns for the Report Formatter by placing a security code on any field to prevent it from printing on the report for unauthorized users.

**Setting up general ledger breaks for Report Formatter**

When setting up GL breaks in Trial Balance Total Breaks F/M (GLF960), each set of Total Group GL breaks must include the entire range of GL numbers. For example, if you have GL numbers that range from 1000 to 4000 and want to enter a break at GL number 2500 for Total Group 1, you must also enter another break for Total Group 1 that would include the highest GL number, in this example, 4000. The same is true for any Total Group entered. So, if you enter a break for Total Group 2 that ends at GL number 2000, you would need to enter another break for Total Group 2 that ends at or beyond GL number 4000. Failure to enter the breaks as described will result in formatting problems with the report. Note that prior to this report being converted to use the Report Formatter, the above requirement did not apply. This requirement is a result of limitations introduced by the Report Formatter.

**FACTS Report Registers**

*Registers* print information and then provide an optional update, which posts the register information to the appropriate files. For example, after invoices are printed, they print on the SO Daily Sales Register. If you update the register, the invoices then post to the open receivables file, sales tax file, etc.

Most report, print and register programs allow you to

- Select the *order* in which you want the information to print,
- Set a *range* of information to print and
- Edit *properties*, which vary with each report.

For example, the AR reports give you the option of printing in customer number, alphabetical, salesperson/territory or customer class order. If you choose to print a Customer Listing in customer class order, the report will sort and print all of the customers by class.

Once you select an order you can then choose the *beginning* and *ending order* that you want to print. The system always defaults to FIRST and LAST. These two fields enable you to filter your report by entering ranges. You can select F2 to search for order values for your report.
In the Customer Listing example, you could enter **Retail** for beginning class order and **Retail** for ending class order to generate a report listing just your retail customers.

In addition to order and range, all reports and prints have a variety of properties that enable you to fine tune your reports.

Once you have answered all the questions in the report, click **OK** or press **Enter**.

Most FACTS reports print in 132-column paper (11 ½ x 14 inch paper). However, some reports, such as the Chart of Accounts, print on 80-column paper (8 ½ x 11 inch paper).

The END OF FIELDS statement indicates where 80-column paper may be used.

The following information appears on each page of all reports, except GL financial reports:

- the time and date the report was printed
- the user
- the terminal from which the report was run
- company name
- report name
- program name
- page numbers
- sort order
- beginning and ending range

---

### Reports and Prints menu options

Many reports and prints programs contain the following menu options:

**Template**

**Select**—Allows you to select a template for the report. Refer to the Selecting existing templates topic for more information.

**Save Entries**—Save the current template settings for the report. Refer to the Creating system templates or Editing the order, range and properties stored in templates topics for more information.

**Create**—Allows you to create a template for the reports. Refer to the Creating system templates topic for more information.

**Properties**—Allows you to set printer properties for the template used by the report. Refer to the Setting printer properties in templates topic for more information.

**Clear**—Clears the settings for the template and resets it back the report’s original default values. Refer to the Clearing a template topic for more information.

**Print Options**

**Properties**—Allows you to select the type of output device to which the report should print, select or deselect beginning and ending form feeds and adjust the number of lines in the top
and bottom margins. Refer to the Using print options in reports and Setting a default printer using templates topics for more information.

Note: If the report is configured to use the FACTS Report Formatter and more than one print or output option exists for the report, the system displays the Multiple Output Selection screen instead of the Print Options screen.

**Custom report layout**

(For reports with the FACTS Report Formatter feature enabled.)

**Customize Report**—Allows you to customize the report by specifying a format and creating custom report layouts.

**Security**—Allows you to manage security for each field on the report. You can set fields to be permanently hidden and lock fields with a security code. (The Security menu option can only be administered by a user that is set up as a Reports administrator. Changes made are effective for all users.)

**Report features at glance**

It's easy to run the Reports you need in FACTS. System and personal templates help save time and printer options give you control.

Set up an unlimited number of personal templates. Templates allow you to save a combination of entries for later use.

Select, edit or delete templates. You can also change template properties, including printer settings.

The system saves the last nine templates you've used in the Options menu for easy access.

Set up and manage system templates that all FACTS users can access (requires security codes).

Print reports to FACTS printers, viewers, flat files, VSI-FAX and Archive.

Select or deselect beginning and ending form feeds as needed.

Control number of lines in report margins
Setting the default printer (SMR999)

Use the Set Default Printer program to set the default printer for the specific report. This setting is specific to the user that set it and company in which the user is working. In the My Default Printer field, enter the printer id that you want to use as the default. Press F2 to search. The program displays the system-wide and company-wide printers is they are set.

Using print options in reports

On each report, you can select the type of output device to which the report should print, select or deselect beginning and ending form feeds and adjust the number of lines in the top and bottom margins.

Print options can be set each time you run the report by selecting Print Options-->Properties. To save time, you can also save print options in templates. For instance, you can create one template so a report outputs to a printer, create another template so the same report outputs to a Fax and then create a third template so the report outputs to the viewer so you can preview it on screen.

Fields for print options

1. Print to option

In FACTS, you can output reports to a printer, viewer, flat file or you can output to other software packages, such as VSI-Fax or Archive.

**Printer** gives you access to any of the FACTS printers set up in Printer F/M and any of the outputs set up in Output Options F/M Select the printer or output option from the dropdown list or search for available printers.

**Viewer** enables you to review a report on screen. The Viewer is also equipped with print capabilities, as well as a clipboard feature.

**File** lets you print the report to a flat file format. This enables you to import report information into other software programs such as spreadsheets, databases, word processors. You can also attach the flat files to e-mail messages. FACTS automatically saves flat files to pvx\fileprt on your local drive. To save the file elsewhere, enter a directory path in front of the file name. For example, C:\My Documents\agedtrial1.txt or [WDX]C:\My Documents\agedtrial1.txt (for Windx connections).

**Fax** sends the report information to VSI-FAX, giving you desktop faxing capabilities. This option is only available on systems using the Faxlink module. If you have questions about this feature, contact your local FACTS Affiliate.

**Archive** is only available on systems using Archive™ software by Designed Data Systems, Inc. This is an on-line storage and retrieval system that lets you automatically build a library of important documents.
2. No. Copies
Enter the number of copies to print of the report. You can specify the number of copies for any output except fax, email and Archive.

3. Layout
From the personal custom layouts and system layouts that are available. Custom Layouts can be chosen when the report is run from the Print Options or the Multiple Output Selection and can be saved into Templates.

Margin Settings

4. Top Margin
Enter the number of lines in the top margin. All FACTS forms print 53 lines per page by default, leaving a top and bottom margin of 5 lines each. You can adjust the number of lines in the top and bottom margins from 0 to 20. The default is 5. Keep in mind that if you increase or decrease the number of lines in the margin, the number of lines in your report will inversely decrease or increase.

5. Bottom Margin
Enter the number of lines in the bottom margin. All FACTS forms print 53 lines per page by default, leaving a top and bottom margin of 5 lines each. You can adjust the number of lines in the top and bottom margins from 0 to 20. The default is 5. Keep in mind that if you increase or decrease the number of lines in the margin, the number of lines in your report will inversely decrease or increase.

5. Begin report with a form feed
Indicates to the system that you want to print a blank form at the beginning of reports.

6. End report with a form feed
Indicates to the system that you want to print a blank form at the end of reports.

7. Multiple option
Use the Multiple option to display the Multiple Output Selection screen. For each output, you can choose the type of output and any applicable information, like Printer Number, File Name, Number of Copies, Standard or Custom Layout (see Custom Layouts below), and margin and form feed preferences.

Viewing reports on screen
The Viewer enables you to review report information on your terminal or screen. Viewers help you control paper by allowing you to preview a document before you print it.

The vertical scroll bar in the graphical viewer enables you to move the selected page up and down within the window. It does not allow you to scroll through the entire document. Use the VCR buttons or the Page input to access various pages within a document.
Using print options in reports

**Starting the viewer.** Make sure you select viewer in *Print Options-->Properties* or the template selected prints to the viewer. Run the report and click **OK** when the program displays a dialogue box that says End of Report.

Once you click **OK**, the viewer automatically opens.

**Exiting the viewer.** Select *File-->Exit* from the menu bar.

**Viewer menu bar**

- Opens another document in the viewer.
- Saves the document as a report file.
- Saves the document as a PDF file.
- Printing from the viewer. Click the Printer button in the menu bar or select *File-->Print* from the menu. Select a printer and number of copies from the Print dialogue box.
- Using the Find feature. To locate a specific date, description or other piece of information in a report, click the Find button or select *Edit-->Find* from the menu bar.
- View single page format.
- View the report in a 2 pages-per-viewing-area format.
- View the report in a 2 pages-per-viewing-area in a book-style format.
- View the report in a 4 pages-per-viewing-area format.
- Fit the report to the page width of the viewing screen.
- Fit the report page to the window.

- Magnifying the report. If the type appears too small on the screen, click the plus button or select *View-->Zoom In*. To reduce magnification, keep clicking the minus button or select *View-->Zoom Out*. You can also enter any Zoom percentage from 1 to 400%. You can also enter a specific page number in the *Page* field located in the menu bar.
- View Banner Information--file properties, such as title, file
Using report templates

Access template features by choosing the Templates menu in a report, print, register program.

The template feature allows you to save a combination of entries so that you don't have to reselect them every time you run the report. Each user can create an unlimited number of templates in any FACTS report.

Templates that store "current period" (or similar values like "system date") resolve to the "current period at the time the report is run" rather than what the "current period" was at the time the template was created. For example: If you save a template for the Cash Receipts & Adjustments Register and select "System Date" for the Date field, when that template is selected to run again (either manually or via Job Stream) the current date is determined using the FACTS system date when the register is run not the date when the template was created.

Once you create templates, you can edit them, delete them or change their properties.

In the Template Properties window, you can change the name of a template, set it as your default template for that report, set up a default printer for that template, select or deselect beginning and ending form feeds and modify report margins.

The system remembers the last nine templates used and displays them at the bottom of the Templates menu for faster access.

Both user-specific and system templates are specific to the report in which they are created.

Creating user-specific templates

1. On the main report screen, set up the report order, range and properties. Select a printer by choosing Print Options, if necessary.

2. Click Template>Create from the menu bar. The system displays the Creating Template for the accessed report.

3. In the Title field specify the name of the template. Template names can be up to 35 characters long. Make sure the System Template option is not selected. Click OK.

4. Check the System template check box to indicate this template is available throughout the system. System templates are available to any user that has access to the report in which it is created; however not all users can create system templates. Users must have the export security code in their user code profile.

5. Check the Default template check box to indicate this template is the default to use for this report.
Using report templates

6 For the Print to option select the output type for the template. In FACTS, you can output reports to a printer, viewer, flat file or you can output to other software packages, such as VSI-Fax or Archive. Select from:

**Printer** gives you access to any of the FACTS printers set up in Printer F/M. Select the printer from the dropdown list, or press F2 to search for available printers.

**Viewer** enables you to review a report on screen. Both the graphical and character viewers have search and scrolling capabilities. The Viewer is also equipped with print capabilities, as well as a clipboard feature.

**File** lets you print the report to a flat file format. This enables you to import report information into other software programs such as spreadsheets, databases, word processors. You can also attach the flat files to e-mail messages. FACTS automatically saves flat files to pvx\fileprt on your local drive. To save the file elsewhere, enter a directory path in front of the file name. For example, C:\My Documents\agedtrial1.txt.

**Fax** sends the report information to VSI-FAX, giving you desktop faxing capabilities. This option is only available on systems using the FaxLink module. If you have questions about this feature, contact your local FACTS Affiliate.

**Archive** is only available on systems using Archive™ software by Designed Data Systems, Inc. This is an on-line storage and retrieval system that lets you automatically build a library of important documents.

7 In the Margin Settings section of the screen, enter the number of lines in the top and bottom margins for the **Lines Margin**. All FACTS forms print 53 lines per page by default, leaving a top and bottom margin of 5 lines each. You can adjust the number of lines in the top and bottom margins from 1 to 20. The default is 5. Keep in mind that if you increase or decrease the number of lines in the margin, the number of lines in your report will inversely decrease or increase.

8 Click **Begin report with a form feed** to indicate to the system that you want to print a blank form at the beginning of reports.

9 Click **End report with a form feed** to indicate to the system that you want to print a blank form at the end of reports using this template.

**Creating system templates**

Follow the same steps for creating user-specific templates, but select the System Template option. System templates are available to any user that has access to the report in which it is created; however not all users can create system templates. Users must have the export security code in their user code profile.

**Setting a default printer using templates**

1 Click **Print Options>Properties** from the menu.

2 Select the printer you want to use as your default and click **OK**.

3 Click **Template>Create** if you want to create a new template, or if you have a template selected, click **Template>Save Entries**.
Using report templates

Selecting existing templates

1 Click Template>Select from the menu bar.
2 In the Report Templates window, select the template you want to use.
3 Click OK. The name of the template appears on the bottom of the main report screen.

Setting a default template

You can flag a template so it is selected every time you open the report.

1 Click Template>Properties from the menu bar.
2 In the Template Properties window, click Set as Default Template.
3 Click Save.

Clearing a template

This feature enables you to reset a template back the report’s original default values. When you clear templates, None appears under the Template header at the bottom of the window, indicating that a template is not selected.

1 Click Template>Clear.
2 Once you clear a template, you can:
   • select it again (Templates>Select) and reset the order, range properties and printer, or
   • delete it.

Deleting a template

1 Click Template>Properties.
2 Select the template from the list box in the Report Templates window and click Delete.

Changing a template name

1 With the template selected, click Template>Properties from the menu bar.
2 In the Properties window, type the new template name.
3 Click OK.

Editing the order, range and properties stored in templates

1 Select the template if it’s not selected already.
2 Change the order, range or properties on the main screen.
3 Click Templates>Save Entries from the menu bar.
4 A dialog box is displayed confirming the changes. Click OK to return to the main screen.
Using report templates

Setting printer properties in templates
Each template can have its own printer properties so that you don’t have to set them each time you print the report. However, you can override the template print options on a print-by-print basis by selecting Printer Options from the main report window.

1. With the template selected, click Templates>Properties from the menu bar.
2. Set the print options in the lower portion of the window.
3. Click OK to return to the main report window.

Using the Multiple Output Selection screen
Use the Multiple Output Selection screen to choose the type of output and enter any applicable information, like Printer Number, File Name, Number of Copies, Standard or Custom Layout (see Custom Layouts below), and margin and form feed preferences for each output you select.

When you click Multiple on the Print Options screen, the system displays the selected Print To option information as the default in the upper portion of the screen.

Note: If a FACTS report program is configured to use the FACTS Report Formatter and more than one print or output option exists for the report, the system displays the Multiple Output Selection screen instead of the Print Options screen.

To modify this information, highlight the Print to option in the browser in the lower portion of the screen and edit.

Fields for Multiple Output Selection

1. Print to option

In FACTS, you can output reports to a printer, viewer, flat file or you can output to other software packages, such as VSI-Fax or Archive.

Printer gives you access to any of the FACTS printers set up in Printer F/M and any of the outputs set up in Output Options F/M. Select the printer or output option from the dropdown list to search for available printers.

Viewer enables you to review a report on screen. The Viewer is also equipped with print capabilities, as well as a clipboard feature.

File lets you print the report to a flat file format. This enables you to import report information into other software programs such as spreadsheets, databases, word processors. You can also attach the flat files to e-mail messages. FACTS automatically saves flat files to pvx\fileprt on your local drive. To save the file elsewhere, enter a directory path in front of the file name. For example, C:\My Documents\agedtrial1.txt or [WDX]C:\My Documents\agedtrial1.txt (for Windx connections).

Fax sends the report information to VSI-FAX, giving you desktop faxing capabilities. This option is only available on systems using the Faxlink module. If you have questions about this feature, contact your local FACTS Affiliate.
Archive is only available on systems using Archive™ software by Designed Data Systems, Inc. This is an on-line storage and retrieval system that lets you automatically build a library of important documents.

2. No. Copies
Enter the number of copies to print of the report. You can specify the number of copies for any output except fax, email and Archive.

3. Layout
From the personal custom layouts and system layouts that are available. Custom Layouts can be chosen when the report is run from the Print Options or the Multiple Output Selection and can be saved into Templates.

Margin Settings

4. Top Margin
Enter the number of lines in the top margin. All FACTS forms print 53 lines per page by default, leaving a top and bottom margin of 5 lines each. You can adjust the number of lines in the top and bottom margins from 0 to 20. The default is 5. Keep in mind that if you increase or decrease the number of lines in the margin, the number of lines in your report will inversely decrease or increase.

5. Bottom Margin
Enter the number of lines in the bottom margin. All FACTS forms print 53 lines per page by default, leaving a top and bottom margin of 5 lines each. You can adjust the number of lines in the top and bottom margins from 0 to 20. The default is 5. Keep in mind that if you increase or decrease the number of lines in the margin, the number of lines in your report will inversely decrease or increase.

5. Begin report with a form feed
Indicates to the system that you want to print a blank form at the beginning of reports.

6. End report with a form feed
Indicates to the system that you want to print a blank form at the end of reports.

In the browser in the lower portion of the field, the system displays any existing or newly added Print To/Output options. You can highlight a Print To/Output line and delete it. When you have finished adding/editing/deleting outputs for the report, save your changes and click Done to return to the report. Click Cancel to exit without saving your changes.

Tip: Outputs Defined
The difference between a printer (defined in Printer F/M) and an output option (as defined in the new Output Options F/M) is that output options have expanded functionality. These are the advantages of output options.

Printing to new output types--When creating a report as a file, an administrator user can control file output to always be placed on the client PC or always on the server
When creating a report as a file, an administrator or user can control what the filename will be with run-time replacements (see below for an explanation of what these are).
Output can be customized with open, close, post-open, pre-close, and post close procedures.

Regular printers (printers set up in Printer F/M) can still be used.

**Register formats and procedures**

Registers are similar to reports, with one significant difference. Where a report only prints information, a register prints the information and then optionally updates it to the appropriate files in the system.

Registers are found on the menu where the information was entered. For example, in AP, documents (invoices) are entered through the Document Entry Program on the document entry menu, and will update a document entry file. Users then print the Document Entry & Adjustments Register (also found on the document entry menu), which will provide an audit trail of what documents were entered. After the register is printed, it should be verified and if all the information is correct it may be updated. The update posts the documents entered to the open payables file.

**Running registers**

1. Set the appropriate order, range and parameters and print the register.
2. Review the register print out and verify that the information is correct before you update. If you find errors, return to the appropriate entry or adjustment program to make the corrections.
3. If the module is set to print GL distributions, print and review the GL distribution to make sure transactions balance. Make any necessary adjustments.
4. Once the register and GL distribution are correct, proceed with the update.

**Audit trails**

It is good practice to save all registers as audit trails. Whenever you run a register, it provides an audit trail of the information that has been entered and is updated in the appropriate files. Once you update a register, the information can no longer be printed.

An example is the AR Cash Receipts & Adjustment Register. Payments are posted in the AR Cash Receipts & Adjustments Entry program.

Files are not updated until you print and update the register. The AR Cash Receipts & Adjustments Register provides an audit trail of the payments, discounts, adjustments and miscellaneous cash posted.

The register has a number assigned to it. These numbers update by 1 each time someone updates the register.
All registers throughout the FACTS system work the same way. Therefore, all registers that are updated should be filed in numerical order by register type.

Using reports, registers and prints as audit trails

Once you run a register in FACTS, the information updated by that register is no longer available in the system in that format.

An example is the AR Cash Receipts & Adjustment Register. Payments are posted in the AR Cash Receipts & Adjustments Entry program. The register provides an audit trail of the payments, discounts, adjustments and miscellaneous cash posted. The register has a number assigned to it. FACTS updates these numbers by one each time you run the register. Once this register runs, the information it has collected is written to various programs within the system.

This is why all FACTS registers allow you to print a hardcopy before you run them. The hardcopy gives you the opportunity to review the data, catch any errors and fix the mistakes before they run registers.

They also serve as audit trails that can be used to help reconcile data later on in the fiscal cycle, and they provide an additional source of backup in case you lose register information.

How long you save these printouts depends your company’s needs. We recommend that you save them in numerical order and by register type.

FACTS Report Designer

Use the FACTS Report Designer to create Custom Report Layouts. You can customize each report layout in many ways:

- Remove a field from the report
- Add a new field to the report
- Change column header titles
- Change which columns get totaled
- Change the width of fields and their header titles
- Change XML tags on a field-by-field basis for each layout

Once you create your own layout, you can name the layout and save it for easy access in the future. The layout can be a Personal or System layout and if desired, can be set as a user’s default layout. Report templates will indicate which layout you prefer.

1 To access this screen click Layout on the Customize Report (SMR999.U) screen. The system displays the report name, report format and tier at the top of the screen as the default.
Using reports, registers and prints as audit trails

2. You can:
   - **Drag and drop fields**—you can rearrange the fields in each tier.
   - **Hide fields**—you can suppress fields from the report by right clicking on the field and clicking Hide.
   - **Add fields**—you can add fields by right clicking on a blank area and choosing the Select Field to Place Here option. The system displays the Place Information Field Search screen where you can choose a field to add to the report. Note: Most fields from the files that relate to the report will be available. For instance, the Customer Report can be modified to add almost any Customer File or Ship-To field.
   - **Edit fields**—you can edit fields by right clicking on the field and click **Edit** to display the Edit Field Attributes screen.

Customizing reports

Use the Customize Report (SMR999.U) program to associate formats, custom layouts, xml tags and tiers to reports. You can access the Customize Report program from Custom Report Layout menu.

Custom Layouts can be chosen when the report is run from the Print Options or the Multiple Output Selection and can be saved into Templates.

**Fields for customizing reports**

The system displays the report program name at the top of the screen as the default.

1. **Format**

   Select a format to associate with the customized report. For each format, users can create a custom layout (a format is a way that the report is run, like a sort order, or summary vs. detail). It’s important to note what report elements make up a format for that report. For instance, if you customize the Customer Listing’s General Info format, those changes will not apply to the Customer Listing’s History format.

2. **Layout**

   Enter a layout to use to customize the report.

3. **Description**

   Enter a description of the report layout.

4. **System Layout**

   Indicate whether you want this report layout to be available as a system layout.

5. **Max Width**

   Enter the maximum width in columns for the report layout.

6. **Report XML Tag**
Enter the XML tag for the report. (This is particularly useful for supply chain management needs.)

7. Format XML Tag

Enter the XML tag for the report format. The report format XML tag allows printing directly to a TCP/IP port or to a file with customized XML tags for each supply chain partner.

Tier Section

Each format contains tiers—the different groupings that contain data elements on the report. You can edit the tiers by highlight a tier in the line item browser in the lower portion of the screen and pressing the Edit icon.

You can edit the following fields for each tier:

8. Suppress Printing:

Use the dropdown list to indicate how to suppress printing. You can select from:

- **D-Use Default**—None of the tier’s fields will be printed, but the records will be processed. Sub-tiers will not be suppressed.
- **Y-Yes**—Suppress Printing.
- **N-No**—Print This Tier

9. Totals Only

Use the dropdown list to indicate how to print totals. You can select from:

- **D-Use Default**—Print only a total line for each tier.
- **Y-Yes**.
- **N-No**

10. Beginning of Tier:

Use the dropdown list to choose spacing preferences for the beginning of the tier. You can select from:

- **D-Use Default**.
- **N-Nothing**
- 1—1 Line Feed
- 2—2 Line Feeds
- 3—3 Line Feeds
- **P—Page Break**

11. End of Line:

Use the dropdown list to choose spacing preferences for after each line. You can select from:

- **D-Use Default**.
- **N-Suppress LF**
- **L—Line Feed**
- 1—1 Blank Line
Using reports, registers and prints as audit trails

- 2—2 Blank Lines
- P—Page Break

12. End of Tier:
Use the dropdown list to choose spacing preferences for the end of the tier. You can select from:
- D-Use Default.
- N-Nothing
- 1—1 Line Feed
- 2—2 Line Feeds
- 3—3 Line Feeds
- P—Page Break

13. Print Count
Use the dropdown list to choose print count settings. You can select from:
- D-Use Default
- Y-Yes.
- N-No

14. Suppress Printing Totals
Note that setting this field to "Yes" will cause the totals not to print at that tier of the report. This does not impact the totals calculations, only whether or not they are printed at that level.
Use the dropdown list to choose print count settings. You can select from:
- D-Use Default.
- N-Nothing
- 1—1 Line Feed
- 2—2 Line Feeds
- 3—3 Line Feeds
- P—Page Break

14. Print Column Headers at Top:
Use the dropdown list to choose print settings for column headers at the top of the page. You can select from:
- D-Use Default
- Y-Yes.—The headers print at the top of the page.
- N-No—The headers print at the top of the tier.

15. Tier XML Tag:
Enter the Tier XML tag according to the requirements of your supply chain partner, if applicable.

16. Line XML Tag
Using reports, registers and prints as audit trails

Enter the Line XML tag according to the requirements of your supply chain partner, if applicable.

You cannot remove a tier from a customized report.

After entering the information you can press:

- **Layout** to access the FACTS Report Designer, where you can change the layout for each tier
- **Security** to access the Security Entry Screen (SMR999.S), where you can manage security for each field on the report layout.

**Editing field attributes**

Use the Edit Field Attributes screen edit the fields in a custom report layout in the FACTS Report Formatter feature.

The system displays the report program name, report format, and reporting information (such as the extension) at the top of the screen as the default.

**Fields for customizing reports**

1. **Print Width**

   Enter the number of character wide to print for the field. You can change the width to your preference, keeping in mind that it is possible to truncate the data.

2. **Print on Continued Line**

   Use the dropdown list to indicate whether to print this field when continuing on a new page.
   You can select from:
   - D-Use Default
   - Y-Yes
   - N-No

3. **XML Tag**

   Enter the XML tag for this field according to the requirements of your supply chain partner, if applicable.

   For numeric fields, choose from the following:

4. **Totaled**

   Indicate whether this field should be totaled. You can select from
   - D-Use Default--Totaled:
   - N-No--Not totaled
   - 1- Total at this level only (for example, on the Stock Status report, total the serial/lot costs after each item)
   - 2-Total at this and all previous levels (for example, total the serial/lot costs after each item and then also at the warehouse level)
Using reports, registers and prints as audit trails

- 3- Total at the top level only (for example, don’t total the serial/lot costs at the item level, but do give a warehouse total for serial/lot costs)

5. Total Only
Use the dropdown list to indicate whether this field is only printed as a total. You can select from:
- D-Use Default
- Y-Yes--The field on each line will not print, but a total will print after all lines are printed.
- N-No

6. Total Type
Use the dropdown list to indicate the type of total for this field. You can select from:
- D-Use Default
- S-Sum,
- A-Average,
- M-Min,
- X-Max, or
- O-Count

7. Rounding:
Use the dropdown list to enter the appropriate rounding rule. You can select from:
- D-Use Default,
- B-Round the field amount before adding to total, or
- A -Round after all fields have been added to the total.

8. Parens for Negative
Use the dropdown list to indicate whether to parans (parenthesis) instead of a minus (–) sign when numbers are negative. You can select from:
- D-Use Default
- Y-Yes --if you want negative numbers for this field to be expressed in parentheses.
- N-No--if you want them to be expressed with a negative sign (-).

9. Comma for Thousands Separator
Use the dropdown list to indicate if you would like commas to separate thousands. You can select from:
- D-Use Default
- Y-Yes
- N-No

10. Column Header
Enter the text of the header column.
11. Header Width
Enter the width of the header text. If the text of the header is wider than the text of the column header, the text will wrap to accommodate the width.

12. Justification
Enter the justification of the report. You can select from:

- D-Use Default
- L-Left,
- R-Right,
- C-Center

Click **File>Save** to save your customized report layout, or click **File>Exit** to exit the screen without saving your layout.

**Setting field security**
Use the Security Entry (SMR999.S) screen to set security for each field in a customize report layout. You can set fields to be permanently hidden and lock fields with a security code. Security Entry processing can only be administered by a user that is set up as a Reports administrator. Changes made are effective for all users.)

You can access this program from the **Security** button on the Customize Report (SMR999.U) program or by clicking the **Custom Report Layout >Security** from the report program menu.

**Fields for customizing reports**
The system displays the report program name at the top of the screen as the default. All fields for the report appear in the browser in the lower portion of the screen. To set security for a field, highlight the field in the browser and **Edit**. At the List From field you can enter the id number or description name or beginning letter to limit the field display listing in the browser.

1. **Permanently hidden**
Indicates that no user can choose the field to be added to the report. If the selected field already exists on a report, the field will not print.

2. **Security Code**
Enter the security code the user must have in order for the field to print on the report. Security can only be administered by a user that is set up as a Reports administrator. Changes made are effective for all users.

Save your security setting to the field or select **Stop** to reset the screen.

**Note**: Security for client-side report output is found on the Security tab of FACTS User Code F/M.
Using searches

The Search icon next to a field indicates that a search is available. Click the icon or press F2 on the keyboard to activate the search.

Performance boosters

Vertical scroll bar

The vertical scroll bar is not always accurate in regards to placement. This is a trade-off for performance. The more accurate this scroll bar is, the slower the search is able to perform.

First and Last record functionality

The Search now does not automatically recognize the "first" and "last" record in a given result set unless the user specifically selects an action (up/down arrow) that causes the Search to "look" forward or backward. A new message has been added for the beginning and end of the result set that informs the user they have reached the "first" or "last" record.

Open orders search

In Sales Orders, Purchase Orders, Accounts Payable and Accounts Receivable Entry and File Maintenance programs, open order searches contain Customer and Ship To fields are available to use to additionally narrow your search results.

Filters

The Filters section of the Search has been limited to Keywords only with all other Filter options accessed via the Filter Selections dialog box.

To use searches:

Complete the steps below to use a search.

1. Select the Sort By option to use to display information in the browser in the lower part of the screen. Note that not all searches contain a Sort By option.

2. Enter the information that you want to look up in the Start With or Go To field.
   Note: If your search is set to a sort order that includes a Starts with option, the Starts with field is displayed first and is the default prompt when you access the Search screen.

3. Use filters to narrow your search.

4. (Optional) If available, switch sort orders.

5. You can also:
   Set search preferences
   Export search results
   Print search results

6. (Optional) You can stop the search.

7. Enter the information that you want to look up in the Starts With or Go To field.
   There are three points to remember about this field:
It is case sensitive. If data was entered into the system with the Caps Lock on, enter the look-up information in ALL CAPS. It is not a filter or a keyword. As you enter look-up information in the Starts With or Go To field, the search program advances the highlight bar to the first closest match. All the searchable information remains in the browser so you can scroll up or down through the entire list. These fields relate to the selected sort order. This is important to remember in searches with multiple sort orders. For instance if you’re in a Customer search with the Customer Number sort order selected, C220 is valid Go To criteria. However, if you switch to the Contact sort order, C220 will take you to the first contact name that starts with C.

The Starts with and Go To field options reposition the search with each character that is keyed into the field. For example, if you typed C in the Starts with field, the search immediately repositions the browser to the first Customer whose customer number begins with a C. Then if you enter a 2 right after the C, the search immediately repositions the browser to the first Customer whose customer number begins with a C2. Entry is Beyond the Last on File. If this message appears, try entering the lookup information in either ALL CAPS or lower case, and make sure the lookup information you entered corresponds to the search order you selected.

8 Use filters to narrow your search. Filters enable you to focus on specific information. When you enter a filter, the search eliminates from the browser any information that doesn’t match the filter criteria. Filters are not case sensitive and they are not tied to the selected search order. In other words, if you enter the keyword copper, the search looks through all information — including alpha, descriptions, contacts, cities, states — and returns any entries that contain that word.

For your filter settings, enter Keywords to find information in your search. Click And/Or to manipulate the keywords. You can use the Go button to invoke any Keyword search capability on demand rather than immediately beginning a search when tabbing out of the Keyword fields. For example: You can enter the first keyword, click And/Or and set a second keyword and then click Go to generate the search.

Note that as a visual cue, the Go button will turn green when you need to select it in order to begin the keyword search.

9 Click Filter to access the Filter Selections dialog box.

Using the Filter Selections Dialog Box

The Filter Selections dialog box contains any additional filter values that are available and has a Clear button to remove any settings that may have been entered previously. After you enter valid values for the available filters and click OK, the Search generates a result set based on the filter criteria. The visual cue that the filter is selected is a check mark displayed on top of the filter button.
Using reports, registers and prints as audit trails

**If available, switch sort orders**

Use sort orders to put information in a certain sequence.

For example, if you are performing a customer search, you have the option of sorting the information according to alpha, customer, contact, phone number or customer class. The information that you sort by appears in the first column of the browser window.

For instance, you may only know the customer by its FACTS customer number (i.e., C100), so you choose to search in customer order. When you do the information in the browser reorders according to customer number and the customer number shifts to the first column position.

**To select a sort order:**

Click on one of the tabs at the top of the window or press the Alt key plus the underlined letter on the tab.

Most searches default to the alpha order if it is available, but you can select which sort order the search defaults to when you open it.

**Stopping the search**

You can stop the search process by selecting the Escape key. Selecting the "Escape" key (as defined in FACTS) when the Search is generating the result set will interrupt the search and almost immediately return any values found matching the search criteria up through the time the "Escape" key was selected.

Scrolling the browser left and right no longer restarts the search.

When a search is generating the result set, clicking your mouse anywhere in the dialog box generates an interrupt to the search. All values found matching the search criteria up through the time the mouse click was detected will be displayed.

**Search features at a glance**

FACTS holds vast amounts of your company's vital information. Powerful searches are accessible throughout FACTS to help you quickly pinpoint and access the data you need.

You can choose which search filters to display on the main search window. These filters apply to all search orders in a particular search.

You can save specific entries that they have entered in filter fields so they appear the next time they open the search.

You can specify which search order the search should default to when it opens.

Because searches serve up more information than what can fit in a search browser, you can scroll left and right to view additional columns of information

You can select which column headers appear in the search browser and in what order they appear. You
can also lock a certain number of columns in place so they stay in view during horizontal scrolls.

Search results can be exported out to a flat file or to MS Excel spreadsheet.

Search results can be output to Windows printers, FACTS printers or a graphical viewer

Technical users can selectively cloak sensitive information in search browsers without costly modifications

Using search preferences

All FACTS searches offer their own user-definable preference settings. These settings allow you to control a number of features, such as the default sort order, the number of lines that appear in the browser, which column headers appear in the browser and which filters appear for each sort order.

To access Preferences, click Options>Preferences from the menu bar.

Default search order: Use this setting to control which sort order appears each time you open the search. If a search only offers one search order, it is selected by default.

To set a default search order, click Options>Preferences from the menu bar. Choose the sort order you want the search to default to each time you open it and make sure the Save As User Defaults option is selected. Click OK to return to the main Search window.

Lines Displayed: Lines Displayed is a drop box giving you the ability to display from a minimum of 4 to a maximum of 20 lines in the Search browser. The default setting is 11 lines.

Save as User Defaults: Select this flag if you want any preferences you have set to remain in effect each time you enter this search. This flag also applies to Column Header settings.

Editing columns for the search browser

1. Click the Columns button in the Preferences window.

2. Use the arrow buttons in the center of the window to select which column headers you want to see in the browser and in which order. Column headers that appear in the left box will appear in the browser. The box on the right contains all the possible column headers you can display. The order in which column headers appear in the left box is the order they will appear in the browser.

3. Enter the Number of Locked Columns. This control enables you to keep a number of columns "locked" so they are always in view as you scroll horizontally.

   Example: You set up your Customer Search Column Headers in the following order: customer number, customer name, street address, city, state, Zip Code, contact and phone number.

   You decide that you always need to see the customer number and customer name when you scroll horizontally so you set the Number of Locked Columns to 2.
Removing preferences

You can remove all user preferences in searches by selecting Options-->Reset to System Defaults in graphical.

Resetting to system defaults clears any saved filters and resets all search preferences back to the default FACTS settings.

Exporting search results

If your user code profile includes the export authorization code, this option allows you to examine FACTS search results in an Excel spreadsheet, or you can export search results to a flat file so they can be used in other programs, such as word processors, contact managers, etc.

Note: You must open the Excel program before exporting a search to Excel.

Exporting search results to Excel

1. Open a search.
2. Use the Go To and Filter fields to locate the information you want.
3. Once you have the desired information in the browser, select Export-->To Excel. FACTS automatically formats the results and sets up column headers.

Exporting search results to a flat file (ASCII)

1. Open a search.
2. Use the Go To and Filter fields to locate the information you want.
3. Once you have the desired information in the browser, select Export-->To Flat File.
4. Name the flat file. You do not have to enter the .txt extension to the file name; it will be added automatically.
5. FACTS saves the flat files to ssi7\fileprt by default. To save the file to another drive and directory, specify the path in front of the file name. 
   Example: C:\My Documents\myflatfile.

Append and Overwrite functionality is also supported for the export process for search results.